Windows Live Mail will not start while called from another app – WLDCore.dll is missing

Issue: I was trying to send a mail from command line (or system call, same error) and got a WLDCore.dll missing.
Clicking an email link in a browser won’t work too.

Observation: Other ways, Windows Live Mail works just fine.

Resolution: Well, apart from uninstalling/reinstalling, search Registry for junk, search Microsoft.com for advices on antivirus/malware checks 😉 and obviously, updates, you only have to copy 1 dll file form an existing folder to the Live Mail folder:

Copy

c:\Program Files (x86)\Windows Live\Shared\wldcore.dll

to

c:\Program Files (x86)\Windows Live\Mail\

Done, integration is OK now.

 

If Live Mail is open, you have to close/open it again.

 

Skype couldn’t connect – what to do when anything else fail

2016-02-06_001025

So easy!

Well, who’s not using skype?

It is available even on TV sets nowadays! (not so practical thou) You read here and there that you should disable firewall, antivirus, router, argue with your ISP (!?!), revert to the previous version, upgrade to the next Windows version (hey, XP users, you really are missing out!), uninstall, delete everything ‘skype’ from %appdata% and thes – if still not working – delete all ‘skype’ from registry ?!? [DO PAY very much attention as not everything ‘skype’ in registry needs to be deleted – au contraire], reinstall.

Observation: from within Skype I could get it to check for newer version – none – succesfully. So internet connection was not an issue.

As everywhere stated, Skype is made by the guys at Microsoft – since the days that all they made had to do with Windows (and it’s components) – so Skype depends on … Internet Explorer. Yes, the wolrd’s most used internet browser to download another browser.

My solution:

As settings in Internet Explorer will willy-nilly affect Skype’s connectivity, the most simple solution is to go to Internet Explorer – Options –  Advanced, or Control Panel – Internet Options – Advanced and use the reset button. What ever speciffic setting did you have – will be gone.

Win 8 and Win 10 users want your Control Panel back? Click here.

My specific solution: (I have a certain Java application that does run only in Internet Explorer, with certain settings)

Internet Options – Advanced – unchecked SSL 3.0. Be sure to have SSL 2.0 checked.
Heartbleed anyone? I don’t know how I got this checked, but this was my issue with Skype.

Voila, Skype connected.